lkml.org 
[lkml]   [2019]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 06/12] i2c: omap: Add the master_xfer_irqless hook

> the subject line of this patch
>
> i2c: omap: Add the master_xfer_irqless hook
>
> still contains the old name of the callback '_irqless'. It should be
> '_atomic' instead.
>
>
> On Wed, Apr 03, 2019 at 02:40:13PM +0200, Wolfram Sang wrote:
> > Add the master_xfer_irqless hook to enable i2c transactions
>
> Here again. It should be 'master_xfer_atomic'.

Yes, thanks, fixed!

> > static int omap_i2c_xfer_msg(struct i2c_adapter *adap,
> > - struct i2c_msg *msg, int stop)
> > + struct i2c_msg *msg, int stop, bool polling)
>
> Nitpick. In the patches for the other drivers the boolean flag is called
> 'atomic' and not 'polling'.

This patch originally is not from me, so I prefer to not change it.
Also, I don't want to enforce strict naming within drivers. As long as
it is readable, I am fine with it.

> > static const struct i2c_algorithm omap_i2c_algo = {
> > - .master_xfer = omap_i2c_xfer,
> > + .master_xfer = omap_i2c_xfer_irq,
> > + .master_xfer_atomic = omap_i2c_xfer_polling,
>
> When consistency with other drivers is a goal, the functions should be
> named like:
>
> .master_xfe = omap_i2c_xfer,
> .master_xfer_atomic = omap_i2c_xfer_atomic,
>
> The first without a suffix and the second with the '_atomic' suffix.

ditto.

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2019-04-16 12:52    [W:0.086 / U:1.312 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site