lkml.org 
[lkml]   [2019]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
SubjectRe: [PATCH 1/4] hwmon: (pmbus) add support for output voltage registers
Date
Hi Guenter,

Thanks for taking the time to review these patches. Please see my
comments inline.

Guenter Roeck writes:

> On Tue, Apr 16, 2019 at 11:36:16AM -0700, Ruslan Babayev wrote:
>> +static ssize_t pmbus_show_operation(struct device *dev,
>> + struct device_attribute *devattr, char *buf)
>> +{
>> + struct sensor_device_attribute *attr = to_sensor_dev_attr(devattr);
>> + struct pmbus_operation *operation = to_pmbus_operation(attr);
>> + struct i2c_client *client = to_i2c_client(dev->parent);
>> + int ret;
>> +
>> + ret = pmbus_read_byte_data(client, operation->page, PMBUS_OPERATION);
>> + if (ret < 0)
>> + return ret;
>> +
>> + if (ret & PB_OPERATION_CONTROL_ON) {
>> + if (ret & PB_OPERATION_MARGIN_HIGH)
>> + return snprintf(buf, PAGE_SIZE, "high\n");
>> + else if (ret & PB_OPERATION_MARGIN_LOW)
>> + return snprintf(buf, PAGE_SIZE, "low\n");
>> + else
>> + return snprintf(buf, PAGE_SIZE, "on\n");
>> + } else {
>> + return snprintf(buf, PAGE_SIZE, "off\n");
>> + }
>> +}
>> +
>> +static ssize_t pmbus_set_operation(struct device *dev,
>> + struct device_attribute *devattr,
>> + const char *buf, size_t count)
>> +{
>> + struct sensor_device_attribute *attr = to_sensor_dev_attr(devattr);
>> + struct pmbus_operation *operation = to_pmbus_operation(attr);
>> + struct i2c_client *client = to_i2c_client(dev->parent);
>> + int ret;
>> + u8 val;
>> +
>> + /*
>> + * sysfs_streq() doesn't need the \n's, but we add them so the strings
>> + * will be shared with pmbus_show_operation() above.
>> + */
>
> Saving a few bytes of data in the driver is not worth such limitations.
> I would not want to have to deal with users sending "echo -n on" to the
> driver and complain that it doesn't work.
>

Sending "echo -n on" works just fine. sysfs_streq ignores \n's as
mentioned in the comment. This was actually shamelessly stolen from
drivers/regulator/virtual.c set_mode().

>> + if (sysfs_streq(buf, "on\n"))
>> + val = PB_OPERATION_CONTROL_ON;
>> + else if (sysfs_streq(buf, "off\n"))
>> + val = 0;
>> + else if (sysfs_streq(buf, "high\n"))
>> + val = PB_OPERATION_CONTROL_ON | PB_OPERATION_ACT_ON_FAULT |
>> + PB_OPERATION_MARGIN_HIGH;
>> + else if (sysfs_streq(buf, "low\n"))
>> + val = PB_OPERATION_CONTROL_ON | PB_OPERATION_ACT_ON_FAULT |
>> + PB_OPERATION_MARGIN_LOW;
>> + else
>> + return -EINVAL;
>> +
>> + ret = pmbus_write_byte_data(client, operation->page,
>> + PMBUS_OPERATION, val);
>> + if (ret < 0)
>> + return ret;
>> +
>> + return count;
>> +}
>> +
> I am not convinced that it is a good idea to implement this as sysfs
> attributes. It is notmally only used in manufacturing, and there the
> registers can be acccessed directly.
>
> Either case, we can not implement this in the pmbus driver as generic code.
> Operation commands are notoriously implemented with slight differences across
> different devices. It would also probably be more appropriate to implement
> as regulator, since it affects setting voltages, not limits.
>

The OPERATION command as well as VOUT_COMMAND and VOUT_MARGIN_{HIGH,LOW}
are standard registers specified in PMBus Spec Part II, Rev 1.2 Section
13. "Output Voltage Related Commands". The devices I have seen so far
(the ones that support voltage margining) all seem to be compliant with
the standard as far as the OPERATION register is concerned.

Some devices like TPS40422 use manufacturer specific registers instead of
VOUT_MARGIN_{HIGH,LOW}. Those can be handled by overriding
{read,write}_word_data to make it look standard to pmbus_core (as I have
done in the PATCH 4/4)

>> +
>> +static const struct pmbus_sensor_attr vout_attributes[] = {
>> + {
>> + .reg = PMBUS_VOUT_COMMAND,
>> + .class = PSC_VOLTAGE_OUT,
>> + .label = "command",
>
> Bad name for a label.

Could you please suggest a better name?

>> static int pmbus_find_attributes(struct i2c_client *client,
>> struct pmbus_data *data)
>> {
>> @@ -1912,6 +2089,12 @@ static int pmbus_find_attributes(struct i2c_client *client,
>> if (ret)
>> return ret;
>>
>> + /* Output Voltage sensors */
>> + ret = pmbus_add_vout_attrs(client, data, "out", vout_attributes,
>> + ARRAY_SIZE(vout_attributes));
>> + if (ret)
>> + return ret;
>> +
>
> The sensors you are adding are not output voltage sensors. They are not
> sensors in the first place, and should probably not be reported as sensor
> values. And setting voltages as limits is really not appropriate.
>

I understand your concerns about exposing these registers as sysfs
entries in hwmon. These devices _are_ voltage regulators, and these
registers are not exactly "sensors", although a lot of the existing
pmbus_core code can be reused by pretending they are. Like VOUT_MODE
exponent handling, linear16 format etc.

I have looked at the regulator framework and into extending the
pmbus_regulator_ops to support voltage margining with standard PMBUS
VOUT_MARGIN registers. My predicament is that regulator framework

1) Does NOT have the concept of "margining".

2) Is not expected to be used at ALL on ACPI based systems. With ACPI
kernel assumes power control is done with Power Resource Objects
(ACPI section 7.1).
The latter is a bigger issue for us - our system is Intel based. It
seems like sysfs attributes is our only option.

How would you feel if these registers (namely OPERATION and
VOUT_MARGIN_{HIGH,LOW}) were exposed only in the drivers without making
any changes to pmbus_core.c? Would these drivers have a chance of
getting upstreamed? I hate the idea of maintaining out-of-tree drivers.
Best regards,
Ruslan

\
 
 \ /
  Last update: 2019-04-17 03:58    [W:0.069 / U:0.292 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site