lkml.org 
[lkml]   [2019]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3 4/4] Input: add Apple SPI keyboard and trackpad driver.
On Wed, 27 Mar 2019 19:45:26 +0100
Greg Kroah-Hartman <gregkh@linuxfoundation.org> wrote:

> > > +// SPDX-License-Identifier: GPL-2.0
> >
> > According to last changes this should be GPL-2.0-only
>
> What "last changes"? "GPL-2.0" is a totally valid SPDX identifier for
> the kernel. Don't buy into the "-only" prefix crud that the newer SPDX
> version adopted for crazy reasons. The in-kernel documentation lists
> the valid identifiers and the version of SPDX we are currently using.

According to: LICENSES/preferred/GPL-2.0

> SPDX-URL: https://spdx.org/licenses/GPL-2.0.html
> Usage-Guide:
> To use this license in source code, put one of the following SPDX
> tag/value pairs into a comment according to the placement
> guidelines in the licensing rules documentation.
> For 'GNU General Public License (GPL) version 2 only' use:
> SPDX-License-Identifier: GPL-2.0
> or
> SPDX-License-Identifier: GPL-2.0-only
> For 'GNU General Public License (GPL) version 2 or any later version' use:
> SPDX-License-Identifier: GPL-2.0+
> or
> SPDX-License-Identifier: GPL-2.0-or-later

So, GPL-2.0 is the same as GPL-2.0-only. Changing it from one to the
other doesn't make any difference.

-- Steve

\
 
 \ /
  Last update: 2019-03-27 20:16    [W:0.073 / U:2.636 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site