lkml.org 
[lkml]   [2019]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] usb: dwc3: Softdep for GBit Ethernet on Odroid XU4
On Fri, Mar 22, 2019 at 09:41:57PM +0100, Jochen Sprickerhof wrote:
> Hi Greg,
>
> * Greg Kroah-Hartman <gregkh@linuxfoundation.org> [2019-03-22 06:37]:
> > On Thu, Mar 21, 2019 at 09:23:03PM +0100, Jochen Sprickerhof wrote:
> > > This adds a soft dependency to the dwc3 module to load it after
> > > xhci-plat as proposed in:
> > >
> > > https://marc.info/?l=linux-usb&m=155230272022603&w=2
> > >
> > > Old behaviour:
> > >
> > > $ lsusb -t
> > > /: Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
> > > /: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
> > > |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=r8152, 480M
> > >
> > > New behaviour:
> > >
> > > $ lsusb -t
> > > /: Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
> > > |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=r8152, 5000M
> > >
> > > Tested on Debian unstable using Linux 4.19.29.
> > >
> > > Note, this needs a hard reset when coming from an unpatched kernel.
> > >
> > > Signed-off-by: Jochen Sprickerhof <git@jochen.sprickerhof.de>
> > > ---
> > > drivers/usb/dwc3/core.c | 1 +
> > > 1 file changed, 1 insertion(+)
> > >
> > > diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
> > > index 103807587dc6..9017e4ed9d99 100644
> > > --- a/drivers/usb/dwc3/core.c
> > > +++ b/drivers/usb/dwc3/core.c
> > > @@ -1746,3 +1746,4 @@ MODULE_ALIAS("platform:dwc3");
> > > MODULE_AUTHOR("Felipe Balbi <balbi@ti.com>");
> > > MODULE_LICENSE("GPL v2");
> > > MODULE_DESCRIPTION("DesignWare USB3 DRD Controller Driver");
> > > +MODULE_SOFTDEP("pre: xhci_plat_hcd");
> >
> >
> > Your patch is corrupted and can not be applied :(
>
>
> I'm sorry to hear that. For me this works:
>
> git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
> cd linux
> curl "https://lore.kernel.org/lkml/20190321202303.GA1399@vis/raw" | git am -
>
> But I found some archives that seems to have fiddled with the Content-Type
> of my signed mail, making it fail. Can you send more information about the
> corruption?

Maybe it works if I look at the raw email, but just from the above text,
your leading ' ' characters are dropped, so that's why I emailed you
this.

Let me go look at the message I received...

Ah, yeah, the raw message is correct, it just has a gpg signature which
messed with my email client's display somehow and dropped those leading
spaces.

Sorry for the noise, all is good.

greg k-h

\
 
 \ /
  Last update: 2019-03-23 07:06    [W:0.039 / U:2.244 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site