lkml.org 
[lkml]   [2019]   [Mar]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH 3/3] rhashtable: rename rht_for_each*continue as *from.
On Sun, Mar 17 2019, Miguel Ojeda wrote:

> On Thu, Mar 14, 2019 at 6:10 AM NeilBrown <neilb@suse.com> wrote:
>>
>> The pattern set by list.h is that for_each..continue()
>> iterators start at the next entry after the given one,
>> while for_each..from() iterators start at the given
>> entry.
>>
>> The rht_for_each*continue() iterators are documented as though the
>> start at the 'next' entry, but actually start at the given entry,
>> and they are used expecting that behaviour.
>> So fix the documentation and change the names to *from for consistency
>> with list.h
>
> Thank you for taking care of the .clang-format changes!

:-) that's what "git grep" is for!

>
> Acked-by: Miguel Ojeda <miguel.ojeda.sandonis@gmail.com>

Thanks,
NeilBrown

>
> Cheers,
> Miguel
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2019-03-18 01:16    [W:0.121 / U:13.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site