lkml.org 
[lkml]   [2019]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/3] rhashtable: rename rht_for_each*continue as *from.
On Thu, Mar 14, 2019 at 04:05:28PM +1100, NeilBrown wrote:
> The pattern set by list.h is that for_each..continue()
> iterators start at the next entry after the given one,
> while for_each..from() iterators start at the given
> entry.
>
> The rht_for_each*continue() iterators are documented as though the
> start at the 'next' entry, but actually start at the given entry,
> and they are used expecting that behaviour.
> So fix the documentation and change the names to *from for consistency
> with list.h
>
> Signed-off-by: NeilBrown <neilb@suse.com>
> ---
> .clang-format | 8 ++++----
> include/linux/rhashtable.h | 40 ++++++++++++++++++++--------------------
> lib/rhashtable.c | 2 +-
> 3 files changed, 25 insertions(+), 25 deletions(-)

Acked-by: Herbert Xu <herbert@gondor.apana.org.au>

Thanks,
--
Email: Herbert Xu <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt

\
 
 \ /
  Last update: 2019-03-15 06:51    [W:0.046 / U:2.108 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site