lkml.org 
[lkml]   [2019]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: disabling secondary CPU hangs / system fails to suspend with kernel 4.19+
On Fri, Mar 15, 2019 at 12:41:00PM +0100, Thomas Müller wrote:

> > What .config do you have?
> The one packaged by Fedora. I've attached the one for 4.20.15 as reference.

Thanks, I'll have a poke, see what, if anything, is different from the
kernels I ran.

> > And what, if anything do you see on the
> > console when it goes funny?
> Nothing unfortunately.
> When trying to suspend the display immediately goes blank, the system becomes unresponsive and the
> status LED within the power button start flashing rapidly (just like it does when the power cord is
> attached).
>
>
> > I think you wrote that hot-un-plug never completes? Is there anything in
> > dmesg when it's stuck in:
> >
> > echo 0 > /sys/devices/system/cpu/cpu1/online
> >
> > ?
> I've just tried that again and the system immediately froze.

Hmm, I tought you said the system remained semi usable, just that reboot
stopped working thereafter and it needed a power cycle.

> `journalctl -f` was running in a second window but it had no chance to output anything... :/

Ah, you're using a GUI!

Stop doing that ;-)

See if you can use the VGA console; not a FB console or a DRM console,
but the real ancient, proper text mode, VGA console.

Now, don't ask me how to do that, because I don't know, I've been
running on pure serial console output for the past 10 years or so, heck
I don't even have systemd.

And you might have to do something like: dmesg -n8, to get the console
to print the kernel messages or something.

\
 
 \ /
  Last update: 2019-03-15 13:16    [W:0.061 / U:6.396 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site