lkml.org 
[lkml]   [2019]   [Feb]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 5/5] dax: "Hotplug" persistent memory for use like normal RAM
From
Date
Le 11/02/2019 à 17:22, Dave Hansen a écrit :

> On 2/9/19 3:00 AM, Brice Goglin wrote:
>> I've used your patches on fake hardware (memmap=xx!yy) with an older
>> nvdimm-pending branch (without Keith's patches). It worked fine. This
>> time I am running on real Intel hardware. Any idea where to look ?
> I've run them on real Intel hardware too.
>
> Could you share the exact sequence of commands you're issuing to
> reproduce the hang? My guess would be that there's some odd interaction
> between Dan's latest branch and my now (slightly) stale patches.
>
> I'll refresh them this week and see if I can reproduce what you're seeing.

# ndctl disable-region all
# ndctl zero-labels all
# ndctl enable-region region0
# ndctl create-namespace -r region0 -t pmem -m devdax
{
"dev":"namespace0.0",
"mode":"devdax",
"map":"dev",
"size":"1488.37 GiB (1598.13 GB)",
"uuid":"ad0096d7-3fe7-4402-b529-ad64ed0bf789",
"daxregion":{
"id":0,
"size":"1488.37 GiB (1598.13 GB)",
"align":2097152,
"devices":[
{
"chardev":"dax0.0",
"size":"1488.37 GiB (1598.13 GB)"
}
]
},
"align":2097152
}
# ndctl enable-namespace namespace0.0
# echo -n dax0.0 > /sys/bus/dax/drivers/device_dax/remove_id
<hang>

I tried with and without dax_pmem_compat loaded, but it doesn't help.

Brice

\
 
 \ /
  Last update: 2019-02-12 21:00    [W:0.116 / U:0.008 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site