lkml.org 
[lkml]   [2019]   [Dec]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/2] mfd: cros_ec: Add usbpd-notify to usbpd_charger
From
Date
Hi Prashant,

This should be [PATCH v3 2/2]. All the patches in the series should have the
same version otherwise makes difficult to follow.

Thanks,
Enric

On 19/12/19 21:13, Prashant Malani wrote:
> Add the cros-usbpd-notify driver as a cell for the cros_usbpd_charger
> subdevice on non-ACPI platforms.
>
> This driver allows other cros-ec devices to receive PD event
> notifications from the Chrome OS Embedded Controller (EC) via a
> notification chain.
>
> Change-Id: I4c062d261fa1a504b43b0a0c0a98a661829593b9
> Signed-off-by: Prashant Malani <pmalani@chromium.org>
> ---
> drivers/mfd/cros_ec_dev.c | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/drivers/mfd/cros_ec_dev.c b/drivers/mfd/cros_ec_dev.c
> index c4b977a5dd966..1dde480f35b93 100644
> --- a/drivers/mfd/cros_ec_dev.c
> +++ b/drivers/mfd/cros_ec_dev.c
> @@ -85,6 +85,9 @@ static const struct mfd_cell cros_ec_sensorhub_cells[] = {
> static const struct mfd_cell cros_usbpd_charger_cells[] = {
> { .name = "cros-usbpd-charger", },
> { .name = "cros-usbpd-logger", },
> +#ifndef CONFIG_ACPI
> + { .name = "cros-usbpd-notify", },
> +#endif
> };
>
> static const struct cros_feature_to_cells cros_subdevices[] = {
>

\
 
 \ /
  Last update: 2019-12-20 09:56    [W:0.114 / U:0.528 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site