lkml.org 
[lkml]   [2019]   [Oct]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [ANNOUNCE] 4.19.72-rt25
Date
Hello Gene,

Am Montag, 7. Oktober 2019, 15:16:04 CEST schrieb Gene Heskett:
> On Monday 07 October 2019 15:10:05 Gene Heskett wrote:
> > Unfortunately, this does not work for the pi3-4 family. When its all
> > pulled in and patched, there is no arch/arm/configs bcm2709_defconfig
> > or bcm2711_defconfig for either a pi3b or the new pi4b.
> >
> > I'll go find the 5.2.14 announce and see if its any more complete.
>
> Its disappeared.

Not quite. Those were never (?) there. ;-)

You'll find those files in the raspberrypi tree [1], but not in mainline.

It is possible to run a vanilla kernel on RPi 1 to 3, I guess the
'multi_v7_defconfig' is a good start for 2 and 3. (This works, I have a
running RPi 3 with unpatched mainline kernel on my desk, without RT however.)

IIRC from linux-arm-kernel list, basic support for RPi 4 is still under review
and not yet present in mainline?

So you could try a RPi 2 or 3 with mainline + RT or you try to apply the RT
patches to the vendor/raspberry tree, but I would not count on anyone
supporting the latter.

HTH & Greets
Alex

[1] https://github.com/raspberrypi/linux

\
 
 \ /
  Last update: 2019-10-09 09:24    [W:0.023 / U:15.908 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site