lkml.org 
[lkml]   [2019]   [Oct]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Serial 8250 DMA Broken on OMAP3630
From
Date
Hi Adam,

On 06/10/19 10:34 PM, Adam Ford wrote:
> Has anyone else had any issues using the CONFIG_SERIAL_8250_DMA on the OMAP?
>
> I can use the DMA on the legacy, omap-serial driver, but when I enable
> the DMA on the 8250-omap driver, I get missing frames in Bluetooth.
>
> The older driver seems to have an ISR that seems to address a variety
> of items compared to the very tiny ISR for 8250-omap.c.
>
> I am not exactly sure where to start, but if someone has any
> suggestions on how I can troubleshoot, please let me know. As of now,
> I have to disable CONFIG_SERIAL_8250_DMA to get the Bluetooth
> connected to UART2 operational on a DM3730 at 3,000,000 baud, but it
> appears to work just fine after some patches I just submitted for
> handling RTS/CTS. The legacy omap-serial driver works fine with DMA.
>

Mainline omap-serial does not support DMA (evident from lack of
dmaengine API calls) and therefore is not a regression. So OMAP3 UART
DMA was never tested at least with 8250 driver.
I am not sure enabling UART DMA on OMAP3 would be a trivial job. We need
analyse of whether all erratas workarounds are implemented and see if
there any difference wrt DMA integration itself. Do we know if UART DMA
ever worked on OMAP3 previously?

> adam
>

--
Regards
Vignesh

\
 
 \ /
  Last update: 2019-10-09 15:43    [W:0.063 / U:2.440 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site