lkml.org 
[lkml]   [2019]   [Oct]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Serial 8250 DMA Broken on OMAP3630
* Adam Ford <aford173@gmail.com> [191009 19:28]:
> On Wed, Oct 9, 2019 at 12:34 PM Tony Lindgren <tony@atomide.com> wrote:
> > From what I recall I tested that DMA on omap3 worked fine with runtime
> > PM for console. Certainly there are issues still remaining though.
> >
> > If you want to disable dma for a specific port, just delete the
> > add /delete-property/dma-names for the port in question in your
> > board specific dts file.
> >
> > See 8250_omap.c for of_property_count_strings(np, "dma-names").
>
> Thank you. That seems to have worked. I'll check the AM3517 when I
> have some time to see if it needs the same patch. For now, I pushed
> the patch to the omap mailing list for the Logic PD Torpedo board.
>
> Should we consider removing the OMAP_SERIAL from omap2plus_defconfig
> in the 8250 is the preferred driver? It seems odd to me that both
> drivers are enabled.

We have CONFIG_SERIAL_8250_OMAP=y and by default also we have
CONFIG_SERIAL_8250_OMAP_TTYO_FIXUP=y. With those omap_serial
won't probe.. So yeah I guess for v5.5 we could drop the
option for CONFIG_SERIAL_OMAP for both omap2plus_defconfig and
multi_v7_defconfig.

Regards,

Tony

\
 
 \ /
  Last update: 2019-10-09 22:17    [W:0.029 / U:38.332 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site