lkml.org 
[lkml]   [2019]   [Oct]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v2 02/22] mtd: spi-nor: Introduce 'struct spi_nor_controller_ops'
Date


On 09/24/2019 10:45 AM, Tudor Ambarus - M18064 wrote:
> From: Tudor Ambarus <tudor.ambarus@microchip.com>
>
> Move all SPI NOR controller driver specific ops in a dedicated
> structure. 'struct spi_nor' becomes lighter.
>
> Use size_t for lengths in 'int (*write_reg)()' and 'int (*read_reg)()'.
> Rename wite/read_buf to buf, the name of the functions are
> suggestive enough. Constify buf in int (*write_reg). Comply with these
> changes in the SPI NOR controller drivers.
>
> Suggested-by: Boris Brezillon <boris.brezillon@collabora.com>
> Signed-off-by: Tudor Ambarus <tudor.ambarus@microchip.com>
> ---
> drivers/mtd/spi-nor/aspeed-smc.c | 23 ++++++-----
> drivers/mtd/spi-nor/cadence-quadspi.c | 39 ++++++++++--------
> drivers/mtd/spi-nor/hisi-sfc.c | 22 +++++-----
> drivers/mtd/spi-nor/intel-spi.c | 24 ++++++-----
> drivers/mtd/spi-nor/mtk-quadspi.c | 25 +++++++-----
> drivers/mtd/spi-nor/nxp-spifi.c | 23 +++++++----
> drivers/mtd/spi-nor/spi-nor.c | 76 ++++++++++++++++++++---------------
> include/linux/mtd/spi-nor.h | 51 +++++++++++++----------
> 8 files changed, 166 insertions(+), 117 deletions(-)

Applied to spi-nor/next.
\
 
 \ /
  Last update: 2019-10-23 23:25    [W:0.233 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site