[lkml]   [2019]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v3 3/7] mm: Add write-protect and clean utilities for address space ranges
On 10/2/19 8:06 PM, Linus Torvalds wrote:
> On Wed, Oct 2, 2019 at 6:48 AM Thomas Hellström (VMware)
> <> wrote:
>> From: Thomas Hellstrom <>
>> Add two utilities to a) write-protect and b) clean all ptes pointing into
>> a range of an address space.
> This one I still don't exactly love.
> I'm not entirely sure what rubs me the wrong way, but part of it is
> naming. We don't use the name "as", because it reads as (sic) an
> English word.
> The name we use for address_space pointers is "mapping", both for
> variables and for existing functions.
> See for example "pte_same_as_swp()" which uses "as" as the _word_ 'as'.
> Contrast that with "unmap_mapping_range()" or
> "mapping_set_unevictable()" or "read_mapping_page()" or
> "invalidate_mapping_pages()", that all work on address spaces.
> So please don't use 'as' as shorthand for that - eithe rin the
> function names or the filename.
> I'm not sure if that's the _only_ thing that raises my heckles when I
> read this patch, but I think it might be. So I'm not saying "ack with
> naming change", but I suspect that if the naming was changed, it would
> look much better to me.
> Yes, it's a bit more typing. But I really think
> "clean_mapping_dirty_pages()" is just not only more in line with the
> mm naming, I think it's a lot more legible and understandable than
> "as_dirty_clean()", which just makes me go "what the heck does that
> function do?"
> And I really think it needs more than just "as" -> "mapping".
> "mapping_dirty_clean()" still makes me go "what?" in a way that
> "clean_mapping_dirty_pages()" does not. One name reads as a series or
> random words, the other reads as a "this is what the function does".
> I know I sometimes get hung up about naming, but I do think naming
> matters. A descriptive name that just reads as what the function does
> makes it much easier to read the logic of code, imnsho.
> Linus

Yes I typically tend towards using a "namespace_object_operation" naming
scheme, with "as_dirty" being the namespace here,

But I'll give it a shot to see if I can rename it more in line with the

Looking at Matthew's suggestion but lining up with
"unmap_mapping_range()", perhaps we could use "clean_mapping_range" and



 \ /
  Last update: 2019-10-02 21:10    [W:0.102 / U:23.600 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site