lkml.org 
[lkml]   [2019]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH v2 1/9] platform/x86: intel_cht_int33fe: Prepare for better mux naming scheme
    Date
    Adding new connections with for the muxes with new
    identifiers. The old connection are left in for now.

    Signed-off-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>
    ---
    drivers/platform/x86/intel_cht_int33fe.c | 8 +++++++-
    1 file changed, 7 insertions(+), 1 deletion(-)

    diff --git a/drivers/platform/x86/intel_cht_int33fe.c b/drivers/platform/x86/intel_cht_int33fe.c
    index 02bc74608cf3..295fe19ad4c2 100644
    --- a/drivers/platform/x86/intel_cht_int33fe.c
    +++ b/drivers/platform/x86/intel_cht_int33fe.c
    @@ -32,7 +32,7 @@ struct cht_int33fe_data {
    struct i2c_client *fusb302;
    struct i2c_client *pi3usb30532;
    /* Contain a list-head must be per device */
    - struct device_connection connections[5];
    + struct device_connection connections[7];
    };

    /*
    @@ -184,6 +184,12 @@ static int cht_int33fe_probe(struct platform_device *pdev)
    data->connections[3].endpoint[0] = "i2c-fusb302";
    data->connections[3].endpoint[1] = "intel_xhci_usb_sw-role-switch";
    data->connections[3].id = "usb-role-switch";
    + data->connections[4].endpoint[0] = "port0";
    + data->connections[4].endpoint[1] = "i2c-pi3usb30532";
    + data->connections[4].id = "orientation-switch";
    + data->connections[5].endpoint[0] = "port0";
    + data->connections[5].endpoint[1] = "i2c-pi3usb30532";
    + data->connections[5].id = "mode-switch";

    device_connections_add(data->connections);

    --
    2.20.1
    \
     
     \ /
      Last update: 2019-01-30 17:05    [W:2.351 / U:0.424 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site