lkml.org 
[lkml]   [2019]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 2/2] mfd: sm501: Use struct_size() in devm_kzalloc()
    On Tue, 22 Jan 2019, Gustavo A. R. Silva wrote:

    > One of the more common cases of allocation size calculations is finding
    > the size of a structure that has a zero-sized array at the end, along
    > with memory for some number of elements for that array. For example:
    >
    > struct foo {
    > int stuff;
    > struct boo entry[];
    > };
    >
    > instance = devm_kzalloc(dev, sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
    >
    > Instead of leaving these open-coded and prone to type mistakes, we can
    > now use the new struct_size() helper:
    >
    > instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
    >
    > This code was detected with the help of Coccinelle.
    >
    > Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
    > ---
    > drivers/mfd/sm501.c | 3 +--
    > 1 file changed, 1 insertion(+), 2 deletions(-)

    Applied, thanks.

    --
    Lee Jones [李琼斯]
    Linaro Services Technical Lead
    Linaro.org │ Open source software for ARM SoCs
    Follow Linaro: Facebook | Twitter | Blog

    \
     
     \ /
      Last update: 2019-01-30 14:36    [W:3.563 / U:0.672 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site