lkml.org 
[lkml]   [2019]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ALSA:usb audio Higher sample rates on usb audio no longer working.
On Thu, 03 Jan 2019 12:43:54 +0100,
Con Kolivas wrote:
>
> Upon switching from 4.19.0 to 4.20.0, pulseaudio started complaining
> that sinks that previously worked are no longer supported.
>
> On 4.19.0 trying 24 bit 88200, 176400, and 192000 I get the following
> output from pulse.
> resampler.c: Forcing resampler 'copy', because of fixed, identical
> sample rates.sink-input.c: Created input 15 "Playback Stream" on
> alsa_output.usb-DSPeaker_Anti-Mode_X4-00.iec958-stereo with sample
> spec float32le 2ch 176400Hz and channel map front-left,front-right
>
> Switching to 4.20 gives me:
> alsa-sink.c: Sink does not support sample rate of 176400 Hz
> and
> alsa-sink.c: Sink does not support sample rate of 88200 Hz
> and
> alsa-sink.c: Sink does not support sample rate of 192000 Hz
>
> Sample rates of 44100, 48000, and 96000 work fine, but 88200, 176400,
> and 192000 no longer work
>
> Switching back to 4.19 immediately fixes the issue.
>
>
> I tried looking through the alsa changelogs but there were too many to
> give an obvious culprit, and haven't had time to do a git bisect. If
> there's an obvious choice patch to back out I'd be grateful for the
> heads up.

Hm, through a quick glance, there hasn't been any relevant changes in
USB-audio part (sound/usb/*). Also, the changes in sound/core/* are
irrelevant with your problem.

So I have no idea what went wrong. The bisection, or at least,
narrowing down the commits would be helpful.


thanks,

Takashi

\
 
 \ /
  Last update: 2019-01-03 14:24    [W:0.081 / U:13.028 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site