lkml.org 
[lkml]   [2019]   [Jan]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v5 2/9] cpufreq: Auto-register the driver as a thermal cooling device if asked
On Tue, Jan 29, 2019 at 8:09 AM Viresh Kumar <viresh.kumar@linaro.org> wrote:
>
> On 29-01-19, 11:50, Amit Kucheria wrote:
> > On Tue, Jan 29, 2019 at 11:16 AM Amit Kucheria <amit.kucheria@linaro.org> wrote:
> > >
> > > On Tue, Jan 29, 2019 at 11:06 AM Viresh Kumar <viresh.kumar@linaro.org> wrote:
> > > >
> > > > On 29-01-19, 10:25, Amit Kucheria wrote:
> > > > > All cpufreq drivers do similar things to register as a cooling device.
> > > > > Provide a cpufreq driver flag so drivers can just ask the cpufreq core
> > > > > to register the cooling device on their behalf. This allows us to get
> > > > > rid of duplicated code in the drivers.
> > > > >
> > > > > In order to allow this, we add a struct thermal_cooling_device pointer
> > > > > to struct cpufreq_policy so that drivers don't need to store it in a
> > > > > private data structure.
> > > > >
> > > > > Suggested-by: Stephen Boyd <swboyd@chromium.org>
> > > > > Suggested-by: Viresh Kumar <viresh.kumar@linaro.org>
> > > > > Signed-off-by: Amit Kucheria <amit.kucheria@linaro.org>
> > > > > Reviewed-by: Matthias Kaehlcke <mka@chromium.org>
> > > > > Tested-by: Matthias Kaehlcke <mka@chromium.org>
> > > > > Acked-by: Viresh Kumar <viresh.kumar@linaro.org>
> > > > > ---
> > > > > drivers/cpufreq/cpufreq.c | 13 +++++++++++++
> > > > > include/linux/cpufreq.h | 9 +++++++++
> > > > > 2 files changed, 22 insertions(+)
> > > > >
> > > > > diff --git a/drivers/cpufreq/cpufreq.c b/drivers/cpufreq/cpufreq.c
> > > > > index e35a886e00bc..0f9b50d3ee91 100644
> > > > > --- a/drivers/cpufreq/cpufreq.c
> > > > > +++ b/drivers/cpufreq/cpufreq.c
> > > > > @@ -19,6 +19,7 @@
> > > > >
> > > > > #include <linux/cpu.h>
> > > > > #include <linux/cpufreq.h>
> > > > > +#include <linux/cpu_cooling.h>
> > > > > #include <linux/delay.h>
> > > > > #include <linux/device.h>
> > > > > #include <linux/init.h>
> > > > > @@ -1318,6 +1319,11 @@ static int cpufreq_online(unsigned int cpu)
> > > > > if (cpufreq_driver->ready)
> > > > > cpufreq_driver->ready(policy);
> > > > >
> > > > > +#if IS_ENABLED(CONFIG_CPU_THERMAL)
> > > > > + if (cpufreq_driver->flags & CPUFREQ_IS_COOLING_DEV)
> > > > > + policy->cdev = of_cpufreq_cooling_register(policy);
> > > > > +#endif
> > > >
> > > > I am not sure if Rafael wanted it this way but maybe something like this:
> > > >
> > > > if (IS_ENABLED(CONFIG_CPU_THERMAL) &&
> > > > cpufreq_driver->flags & CPUFREQ_IS_COOLING_DEV))
> > > > policy->cdev = of_cpufreq_cooling_register(policy);
> > > >
> > > > We never wanted ifdef hackery to be in there :)
> > >
> > > OK, that makes more sense. Should I just send out a fixup patch or the
> > > entire series?
>
> Single patch should be fine I believe.
>
> > FWIW, I checked drivers/cpufreq and drivers/thermal before converting
> > over and there is a mixed use of #if IS_ENABLED and if(IS_ENABLED).
> >
> > Perhaps we should clean it up?
>
> No objections from me on that.

Generally speaking, though, "if (IS_ENABLED(SYMBOL))" can only be used
if all of the symbols in the conditional branch are defined regardless
of whether or not SYMBOL itself is defined, so careful there.

\
 
 \ /
  Last update: 2019-01-29 10:17    [W:0.083 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site