lkml.org 
[lkml]   [2019]   [Jan]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH 00/10] HMM updates for 5.1
    Date
    From: Jérôme Glisse <jglisse@redhat.com>

    This patchset improves the HMM driver API and add support for hugetlbfs
    and DAX mirroring. The improvement motivation was to make the ODP to HMM
    conversion easier [1]. Because we have nouveau bits schedule for 5.1 and
    to avoid any multi-tree synchronization this patchset adds few lines of
    inline function that wrap the existing HMM driver API to the improved
    API. The nouveau driver was tested before and after this patchset and it
    builds and works on both case so there is no merging issue [2]. The
    nouveau bit are queue up for 5.1 so this is why i added those inline.

    If this get merge in 5.1 the plans is to merge the HMM to ODP in 5.2 or
    5.3 if testing shows any issues (so far no issues has been found with
    limited testing but Mellanox will be running heavier testing for longer
    time).

    To avoid spamming mm i would like to not cc mm on ODP or nouveau patches,
    however if people prefer to see those on mm mailing list then i can keep
    it cced.

    This is also what i intend to use as a base for AMD and Intel patches
    (v2 with more thing of some rfc which were already posted in the past).

    [1] https://cgit.freedesktop.org/~glisse/linux/log/?h=odp-hmm
    [2] https://cgit.freedesktop.org/~glisse/linux/log/?h=hmm-for-5.1

    Cc: Andrew Morton <akpm@linux-foundation.org>
    Cc: Felix Kuehling <Felix.Kuehling@amd.com>
    Cc: Christian König <christian.koenig@amd.com>
    Cc: Ralph Campbell <rcampbell@nvidia.com>
    Cc: John Hubbard <jhubbard@nvidia.com>
    Cc: Jason Gunthorpe <jgg@mellanox.com>
    Cc: Dan Williams <dan.j.williams@intel.com>

    Jérôme Glisse (10):
    mm/hmm: use reference counting for HMM struct
    mm/hmm: do not erase snapshot when a range is invalidated
    mm/hmm: improve and rename hmm_vma_get_pfns() to hmm_range_snapshot()
    mm/hmm: improve and rename hmm_vma_fault() to hmm_range_fault()
    mm/hmm: improve driver API to work and wait over a range
    mm/hmm: add default fault flags to avoid the need to pre-fill pfns
    arrays.
    mm/hmm: add an helper function that fault pages and map them to a
    device
    mm/hmm: support hugetlbfs (snap shoting, faulting and DMA mapping)
    mm/hmm: allow to mirror vma of a file on a DAX backed filesystem
    mm/hmm: add helpers for driver to safely take the mmap_sem

    include/linux/hmm.h | 290 ++++++++++--
    mm/hmm.c | 1060 +++++++++++++++++++++++++++++--------------
    2 files changed, 983 insertions(+), 367 deletions(-)

    --
    2.17.2

    \
     
     \ /
      Last update: 2019-01-29 17:55    [W:4.161 / U:0.020 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site