lkml.org 
[lkml]   [2018]   [Aug]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] regulator: bd71837: Remove duplicate assignment for n_voltages of LDO2
Thanks Axel,

On Fri, Aug 24, 2018 at 07:16:12PM +0800, Axel Lin wrote:
> Set it once is enough.
> Also move n_voltages close to volt_table for better readability.
>
> Signed-off-by: Axel Lin <axel.lin@ingics.com>
> ---
> drivers/regulator/bd71837-regulator.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/regulator/bd71837-regulator.c b/drivers/regulator/bd71837-regulator.c
> index 0f8ac8dec3e1..9b5e1297902f 100644
> --- a/drivers/regulator/bd71837-regulator.c
> +++ b/drivers/regulator/bd71837-regulator.c
> @@ -388,10 +388,9 @@ static const struct regulator_desc bd71837_regulators[] = {
> .ops = &bd71837_ldo_regulator_nolinear_ops,
> .type = REGULATOR_VOLTAGE,
> .volt_table = &ldo_2_volts[0],
> + .n_voltages = ARRAY_SIZE(ldo_2_volts),
> .vsel_reg = BD71837_REG_LDO2_VOLT,
> .vsel_mask = LDO2_MASK,
> - .n_voltages = ARRAY_SIZE(ldo_2_volts),
> - .n_voltages = BD71837_LDO2_VOLTAGE_NUM,
> .enable_reg = BD71837_REG_LDO2_VOLT,
> .enable_mask = BD71837_LDO_EN,
> .owner = THIS_MODULE,
> --
> 2.17.1
>

This is how it should have been in the first place!

Br,
Matti Vaittinen

\
 
 \ /
  Last update: 2018-08-27 07:35    [W:0.047 / U:0.108 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site