lkml.org 
[lkml]   [2018]   [Aug]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC][PATCH 00/24] tools lib traceevent: Rename pevent to tep for preparation for library
On Wed, Aug 08, 2018 at 11:55:48AM -0400, Steven Rostedt wrote:
> Having libtraceevent turn into a proper library has long been asked for.
> I never had time to do it before. Luckily, Tzvetomir was able to spend
> the time to start the preparation. The first thing that needs to be done
> is to handle namespace collisions. "pevent" was the prefix I chose, but
> many people were displeased by it, as it didn't express what the functions
> were used for. After discussing with many people at many conferences
> I've come up with "tep", which means "Trace Event Parser". Please don't
> question this. The bikeshed has been painted and I'm not changing the
> color.
>
> This series changes all the function names and data structures from the
> "pevent_" prefix to the "tep_" prefix. Note, it does not change the
> names of local variables or even parameters. "pevent" variables and
> parameters still exist. We can change those later, but for now, I want
> all global references to "pevent" to be "tep_" instead.
>
> This is not complete. It is only one of many preparations to make
> libtraceevent into a legitimate library. There's other naming conventions
> that will be made. But for now, I would like to hear thoughts about
> this change before we proceed further.

right, I can see more things that needs rename, like in print_arg*,
trace_* stuff and others

I'm also getting weird make error when compiling in libtraceevent dir:

[jolsa@krava traceevent]$ make
GEN libtraceevent-dynamic-list
Either missing one of [ plugin_jbd2.so plugin_hrtimer.so plugin_kmem.so plugin_kvm.so plugin_mac80211.so plugin_sched_switch.so plugin_function.so plugin_xen.so plugin_scsi.so plugin_cfg80211.so] or bad version of nm

but that seems to be there even without your patchset,
so probably something we should look into

other than that it looks ok to me

once this is done, we can move forward to put this
to kernel-tools-libs-devel rpm

thanks,
jirka

\
 
 \ /
  Last update: 2018-08-10 11:22    [W:0.074 / U:6.372 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site