lkml.org 
[lkml]   [2018]   [Jul]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [PATCH -mm -v4 01/21] mm, THP, swap: Enable PMD swap operations for CONFIG_THP_SWAP
    Date
    Dan Williams <dan.j.williams@intel.com> writes:

    > On Sun, Jul 8, 2018 at 10:40 PM, Huang, Ying <ying.huang@intel.com> wrote:
    >> Dan Williams <dan.j.williams@intel.com> writes:

    >>> Would that also allow us to clean up the usage of
    >>> CONFIG_ARCH_ENABLE_THP_MIGRATION in fs/proc/task_mmu.c? In other
    >>> words, what's the point of having nice ifdef'd alternatives in header
    >>> files when ifdefs are still showing up in C files, all of it should be
    >>> optionally determined by header files.
    >>
    >> Unfortunately, I think it is not a easy task to wrap all C code via
    >> #ifdef in header files. And it may be over-engineering to wrap them
    >> all. I guess this is why there are still some #ifdef in C files.
    >
    > That's the entire point. Yes, over-engineer the header files so the
    > actual C code is more readable.

    Take pagemap_pmd_range() in fs/proc/task_mmu.c as an example, to avoid
    #ifdef, we may wrap all code between #ifdef/#endif into a separate
    function, put the new function into another C file (which is compiled
    only if #ifdef is true), then change header files for that too.

    In this way, we avoid #ifdef/#endif, but the code is more complex and
    tightly related code may be put into different files. The readability
    may be hurt too.

    Maybe you have smarter way to change the code to avoid #ifdef and
    improve code readability?

    Best Regards,
    Huang, Ying

    \
     
     \ /
      Last update: 2018-07-09 08:34    [W:4.131 / U:0.120 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site