lkml.org 
[lkml]   [2018]   [Jul]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 00/14] crypto: inside-secure - EIP197d support
On Thu, Jun 28, 2018 at 05:15:30PM +0200, Antoine Tenart wrote:
> Hi all,
>
> This series introduces the EIP197d engine support to the Inside Secure
> SafeXcel cryptographic engine driver.
>
> In order to support this new engine, the driver has to be reworked in
> some ways:
> - The firmwares are specific to a given version of an EIP engine: they
> must be stored in a version specific folder.
> - The compatibles have to be reworked, to denote the exact version of
> the engine being used. Note that we kept the backward compatibility.
> - Not all algorithms are supported by all versions of the EIP engine.
>
> Some improvements were also made to the driver, to fully embrace the
> capabilities of this new EIP197d engine, and to improve the existing
> support.
>
> Please note the DT patches (13/14 and 14/14) should go through the mvebu
> tree.

Patches 1-12 applied. Thanks.
--
Email: Herbert Xu <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt

\
 
 \ /
  Last update: 2018-07-08 18:45    [W:0.080 / U:3.736 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site