lkml.org 
[lkml]   [2018]   [Jun]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: AMD graphics performance regression in 4.15 and later
From
Date
Am 06.06.2018 um 13:28 schrieb Gabriel C:
> 2018-04-11 7:02 GMT+02:00 Gabriel C <nix.or.die@gmail.com>:
>>> 2018-04-11 6:00 GMT+02:00 Gabriel C <nix.or.die@gmail.com>:
>>> 2018-04-09 11:42 GMT+02:00 Christian König <ckoenig.leichtzumerken@gmail.com>:
>>>> Am 07.04.2018 um 00:00 schrieb Jean-Marc Valin:
>> ...
>>> I can help testing code for 4.17/++ if you wish but that is *different* storry.
>>>
>> Quick tested an 4.16.0-11490-gb284d4d5a678 , amdgpu and radeon driver
>> are broken now in this one.
>>
>> radeon tells:
>>
>> ...
>>
>> [ 6.337838] [drm] PCIE GART of 2048M enabled (table at 0x00000000001D6000).
>> [ 6.338210] radeon 0000:21:00.0: (-12) create WB bo failed
>> [ 6.338214] radeon 0000:21:00.0: disabling GPU acceleration
>>
>> ...
>>
> I have the same Issue now on final 4.17.

Actually Michel came up with a fix for the performance regression which
is now backported to older kernels as well.

So the original issue of this mail thread should be fixed by now.

> Also I played with BIOS options also which does not fix anything but
> changes the error message.
>
> IOMMU && SR-IOV disabled the error changes to this :
>
> [ 7.092044] [drm:r600_ring_test [radeon]] *ERROR* radeon: ring 0
> test failed (scratch(0x850C)=0xCAFEDEAD)
> [ 7.092059] radeon 0000:21:00.0: disabling GPU acceleration
>
>
> While I could workaround SWIOTLB bugs in 4.15 and 4.16 , 4.17 seems to
> kill the GPU with no way
> for me to make it work ( at least I could not find any workaround by now )

That actually sounds like something completely different. Can you
provide a full dmesg of radeon and/or amdgpu?

Thanks,
Christian.

>
> BR

\
 
 \ /
  Last update: 2018-06-06 13:35    [W:0.049 / U:0.472 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site