lkml.org 
[lkml]   [2018]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v2 01/21] usb: phy: use match_string() helper
From
Date
Hello!

On 05/31/2018 02:11 PM, Yisheng Xie wrote:

> match_string() returns the index of an array for a matching string,
> which can be used instead of open coded variant.
>
> Cc: linux-usb@vger.kernel.org
> Cc: Felipe Balbi <balbi@kernel.org>
> Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
> Signed-off-by: Yisheng Xie <xieyisheng1@huawei.com>
> ---
> v2:
> - donot rename err to ret - per Andy

Hm...

>
> drivers/usb/phy/of.c | 10 +++++-----
> 1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/usb/phy/of.c b/drivers/usb/phy/of.c
> index 1ab134f..9d74081 100644
> --- a/drivers/usb/phy/of.c
> +++ b/drivers/usb/phy/of.c
> @@ -28,16 +28,16 @@
> enum usb_phy_interface of_usb_get_phy_mode(struct device_node *np)
> {
> const char *phy_type;
> - int err, i;
> + int err;
>
> err = of_property_read_string(np, "phy_type", &phy_type);
> if (err < 0)
> return USBPHY_INTERFACE_MODE_UNKNOWN;
>
> - for (i = 0; i < ARRAY_SIZE(usbphy_modes); i++)
> - if (!strcmp(phy_type, usbphy_modes[i]))
> - return i;
> + err = match_string(usbphy_modes, ARRAY_SIZE(usbphy_modes), phy_type);
> + if (err < 0)

This is one of the few cases when 'err' is not the best name for such a
variable. I'd prefer to see something like 'match' or even 'rc' or 'ret'... :-)

> + return USBPHY_INTERFACE_MODE_UNKNOWN;
>
> - return USBPHY_INTERFACE_MODE_UNKNOWN;
> + return err;
> }
> EXPORT_SYMBOL_GPL(of_usb_get_phy_mode);
>

MBR, Sergei

\
 
 \ /
  Last update: 2018-05-31 18:56    [W:0.407 / U:1.720 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site