lkml.org 
[lkml]   [2018]   [May]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v5 01/13] mm: Assign id to every memcg-aware shrinker
From
Date
On 13.05.2018 08:15, Vladimir Davydov wrote:
> On Thu, May 10, 2018 at 12:52:18PM +0300, Kirill Tkhai wrote:
>> The patch introduces shrinker::id number, which is used to enumerate
>> memcg-aware shrinkers. The number start from 0, and the code tries
>> to maintain it as small as possible.
>>
>> This will be used as to represent a memcg-aware shrinkers in memcg
>> shrinkers map.
>>
>> Since all memcg-aware shrinkers are based on list_lru, which is per-memcg
>> in case of !SLOB only, the new functionality will be under MEMCG && !SLOB
>> ifdef (symlinked to CONFIG_MEMCG_SHRINKER).
>
> Using MEMCG && !SLOB instead of introducing a new config option was done
> deliberately, see:
>
> http://lkml.kernel.org/r/20151210202244.GA4809@cmpxchg.org
>
> I guess, this doesn't work well any more, as there are more and more
> parts depending on kmem accounting, like shrinkers. If you really want
> to introduce a new option, I think you should call it CONFIG_MEMCG_KMEM
> and use it consistently throughout the code instead of MEMCG && !SLOB.
> And this should be done in a separate patch.

What do you mean under "consistently throughout the code"? Should I replace
all MEMCG && !SLOB with CONFIG_MEMCG_KMEM over existing code?

>> diff --git a/fs/super.c b/fs/super.c
>> index 122c402049a2..16c153d2f4f1 100644
>> --- a/fs/super.c
>> +++ b/fs/super.c
>> @@ -248,6 +248,9 @@ static struct super_block *alloc_super(struct file_system_type *type, int flags,
>> s->s_time_gran = 1000000000;
>> s->cleancache_poolid = CLEANCACHE_NO_POOL;
>>
>> +#ifdef CONFIG_MEMCG_SHRINKER
>> + s->s_shrink.id = -1;
>> +#endif
>
> No point doing that - you are going to overwrite the id anyway in
> prealloc_shrinker().

Not so, this is done deliberately. alloc_super() has the only "fail" label,
and it handles all the allocation errors there. The patch just behaves in
the same style. It sets "-1" to make destroy_unused_super() able to differ
the cases, when shrinker is really initialized, and when it's not.
If you don't like this, I can move "s->s_shrink.id = -1;" into
prealloc_memcg_shrinker() instead of this.

>> s->s_shrink.seeks = DEFAULT_SEEKS;
>> s->s_shrink.scan_objects = super_cache_scan;
>> s->s_shrink.count_objects = super_cache_count;
>
>> diff --git a/mm/vmscan.c b/mm/vmscan.c
>> index 10c8a38c5eef..d691beac1048 100644
>> --- a/mm/vmscan.c
>> +++ b/mm/vmscan.c
>> @@ -169,6 +169,47 @@ unsigned long vm_total_pages;
>> static LIST_HEAD(shrinker_list);
>> static DECLARE_RWSEM(shrinker_rwsem);
>>
>> +#ifdef CONFIG_MEMCG_SHRINKER
>> +static DEFINE_IDR(shrinker_idr);
>> +
>> +static int prealloc_memcg_shrinker(struct shrinker *shrinker)
>> +{
>> + int id, ret;
>> +
>> + down_write(&shrinker_rwsem);
>> + ret = id = idr_alloc(&shrinker_idr, shrinker, 0, 0, GFP_KERNEL);
>> + if (ret < 0)
>> + goto unlock;
>> + shrinker->id = id;
>> + ret = 0;
>> +unlock:
>> + up_write(&shrinker_rwsem);
>> + return ret;
>> +}
>> +
>> +static void del_memcg_shrinker(struct shrinker *shrinker)
>
> Nit: IMO unregister_memcg_shrinker() would be a better name as it
> matches unregister_shrinker(), just like prealloc_memcg_shrinker()
> matches prealloc_shrinker().
>
>> +{
>> + int id = shrinker->id;
>> +
>
>> + if (id < 0)
>> + return;
>
> Nit: I think this should be BUG_ON(id >= 0) as this function is only
> called for memcg-aware shrinkers AFAICS.

See comment to alloc_super().

>> +
>> + down_write(&shrinker_rwsem);
>> + idr_remove(&shrinker_idr, id);
>> + up_write(&shrinker_rwsem);
>> + shrinker->id = -1;
>> +}

Kirill

\
 
 \ /
  Last update: 2018-05-14 11:04    [W:0.090 / U:1.176 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site