lkml.org 
[lkml]   [2018]   [Mar]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v6 1/5] pwm-backlight: enable/disable the PWM before/after LCD enable toggle.
Hi Pavel,

2018-03-26 12:42 GMT+02:00 Pavel Machek <pavel@ucw.cz>:
> On Mon 2018-03-26 11:52:09, Enric Balletbo i Serra wrote:
>> Before this patch the enable signal was set before the PWM signal and
>> vice-versa on power off. This sequence is wrong, at least, it is on
>> the different panels datasheets that I checked, so I inverted the sequence
>> to follow the specs.
>>
>> For reference the following panels have the mentioned sequence:
>> - N133HSE-EA1 (Innolux)
>> - N116BGE (Innolux)
>> - N156BGE-L21 (Innolux)
>> - B101EAN0 (Auo)
>> - B101AW03 (Auo)
>> - LTN101NT05 (Samsung)
>> - CLAA101WA01A (Chunghwa)
>
> Ok, but this changes behaviour for other panels, too. Are you sure you
> are not breaking one of those?

I can't say that I am 100% sure because I didn't find all the
datasheets of all the panels supported in the kernel. But all the
datasheets I checked specifies this sequence as valid. In general I
think that doesn't really matter, but I know that at least the
B116XTN02 panel requires enable first the PWM, wait 10ms and then
enable BL_EN to avoid garbage. So the other way around is not valid
for this panel. That's the reason for this patchset.

If anyone knows a panel that says the contrary, please let me know and
I'll try to rework the patches to satisfy both requirements.

Regards,
Enric


> Pavel
>
> --
> (english) http://www.livejournal.com/~pavelmachek
> (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

\
 
 \ /
  Last update: 2018-03-26 16:41    [W:0.070 / U:9.136 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site