lkml.org 
[lkml]   [2018]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section
On Thu, Mar 15, 2018 at 04:44:43PM +0100, Borislav Petkov wrote:
> From: Borislav Petkov <bp@suse.de>
>
> The code used to iterate byte-by-byte over the bytes around RIP and that
> is expensive: disabling pagefaults around it, copy_from_user, etc...
>
> Make it read the whole buffer of OPCODE_BUFSIZE size in one go. Use a
> statically allocated 64 bytes buffer so that concurrent show_opcodes()
> do not interleave in the output even though in the majority of the cases
> we sync on die_lock. Except the #PF path which doesn't...
>
> Also, do the PAGE_OFFSET check outside of the function because latter
> will be reused in other context.
>
> Signed-off-by: Borislav Petkov <bp@suse.de>
> ---
> arch/x86/kernel/dumpstack.c | 34 ++++++++++++++++------------------
> 1 file changed, 16 insertions(+), 18 deletions(-)
>
> diff --git a/arch/x86/kernel/dumpstack.c b/arch/x86/kernel/dumpstack.c
> index eb9d6c00a52f..3f781a8dddb8 100644
> --- a/arch/x86/kernel/dumpstack.c
> +++ b/arch/x86/kernel/dumpstack.c
> @@ -22,8 +22,6 @@
> #include <asm/stacktrace.h>
> #include <asm/unwind.h>
>
> -#define OPCODE_BUFSIZE 64
> -
> int panic_on_unrecovered_nmi;
> int panic_on_io_nmi;
> static int die_counter;
> @@ -72,29 +70,25 @@ static void printk_stack_address(unsigned long address, int reliable,
>
> static void show_opcodes(u8 *rip)
> {
> - unsigned int code_prologue = OPCODE_BUFSIZE * 43 / 64;
> - unsigned int code_len = OPCODE_BUFSIZE;
> - unsigned char c;
> +#define OPCODE_BUFSIZE 64
> + unsigned int code_prologue = OPCODE_BUFSIZE * 2 / 3;
> + u8 opcodes[OPCODE_BUFSIZE];

I liked OPCODE_BUFSIZE where it was before :-) Here it disrupts the
readability of the function a bit IMO.

--
Josh

\
 
 \ /
  Last update: 2018-03-15 19:11    [W:0.186 / U:0.540 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site