lkml.org 
[lkml]   [2018]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/3] x86/asm: Add support for WBNOINVD instruction
On Fri, 19 Jan 2018, Kirill A. Shutemov wrote:

> This patch implements infrastructure to call WBNOINVD instruction.

grep 'This patch' Documentation/process/

> The basic idea is to match what we have for WBINVD.

Is it just an idea or is it actually doing it?

> The instruction is defined as WBINVD with REP (0xf3) prefix. If the
> machine doesn't support the instruction the prefix will be ignored and
> we would fallback to WBINVD.

We fallback? We do nothing.

The CPU ignores the prefix and falls back to WBINVD, right?

> +
> +#define wbnoinvd_on_cpu(cpu) wbnoinvd()
> +static inline int wbnoinvd_on_all_cpus(void)

Bah. Please stop glueing defines in front of the function body. That's just
makes it harder to read.

Thanks,

tglx

\
 
 \ /
  Last update: 2018-03-15 10:22    [W:0.043 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site