lkml.org 
[lkml]   [2018]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v4 0/5] y2038: Make ppoll, io_pgetevents and pselect y2038 safe
On 9/20/18, Deepa Dinamani <deepa.kernel@gmail.com> wrote:
> The series transitions the ppoll, io_getevents, and pselect syscalls
> to be y2038 safe.
>
> This is part of the work proceeding for syscalls for y2038.
> It is based on the series [1] from Arnd Bergmann.
>
> The overview of the series is as below:
> 1. Refactor sigmask handling logic for the above syscalls.
> 2. Provide y2038 safe versions of the syscalls for all ABIs.
>
> [1] https://lkml.org/lkml/2018/8/27/651

I'm sorry for dropping the ball on this earlier, so it already
missed the 4.20 merge window, and is getting almost too
late for 4.21 as well now.

I've applied your five patches to my y2038 tree now, so
it should at least be in linux-next as of tomorrow and
make it into 4.21. I'll see what other patches I have in
my backlog that we should get into that release before
I send him a pull request.

Arnd

\
 
 \ /
  Last update: 2018-12-06 17:27    [W:0.038 / U:4.572 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site