lkml.org 
[lkml]   [2018]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v14 01/11] livepatch: Change unsigned long old_addr -> void *old_func in struct klp_func
The 11/29/2018 10:44, Petr Mladek wrote:
> The address of the to be patched function and new function is stored
s/new/the new/
> in struct klp_func as:
>
> void *new_func;
> unsigned long old_addr;
>
> The different naming scheme and type is derived from the way how
s/is/are/
> the addresses are set. @old_addr is assigned at runtime using
> kallsyms-based search. @new_func is statically initialized,
> for example:
>
> static struct klp_func funcs[] = {
> {
> .old_name = "cmdline_proc_show",
> .new_func = livepatch_cmdline_proc_show,
> }, { }
> };
>
> This patch changes unsigned log old_addr -> void *old_func. It removes
> some confusion when these address are later used in the code. It is
> motivated by a followup patch that adds special NOP struct klp_func
> where we want to assign func->new_func = func->old_addr respectively
> func->new_func = func->old_func.
>
> This patch does not modify the existing behavior.
>
> Suggested-by: Josh Poimboeuf <jpoimboe@redhat.com>
> Signed-off-by: Petr Mladek <pmladek@suse.com>

Acked-by: Alice Ferrazzi <alice.ferrazzi@gmail.com>
--
======================================
Alice Ferrazzi
PGP: 2E4E 0856 461C 0585 1336 F496 5621 A6B2 8638 781A
======================================
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2018-12-06 12:08    [W:0.336 / U:10.172 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site