lkml.org 
[lkml]   [2018]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG BISECT] Missing MTD NAND partitions - mtd: rawnand: Move the ->exec_op() method to nand_controller_ops
Hi Krzysztof,

Krzysztof Kozlowski <krzk@kernel.org> wrote on Wed, 5 Dec 2018 17:10:38
+0100:

> On Tue, 20 Nov 2018 at 13:15, Krzysztof Kozlowski <krzk@kernel.org> wrote:
> >
> > On Tue, 20 Nov 2018 at 13:09, Boris Brezillon
> > <boris.brezillon@bootlin.com> wrote:
> > >
> > > On Tue, 20 Nov 2018 12:48:46 +0100
> > > Krzysztof Kozlowski <krzk@kernel.org> wrote:
> > >
> > > > On Tue, 20 Nov 2018 at 11:33, Miquel Raynal <miquel.raynal@bootlin.com> wrote:
> > > > >
> > > > > Hi Krzysztof,
> > > > >
> > > > > Krzysztof Kozłowski <k.kozlowski.k@gmail.com> wrote on Tue, 20 Nov 2018
> > > > > 10:46:33 +0100:
> > > > >
> > > > > > Hi all,
> > > > > >
> > > > > > Since few days linux-next has problem on Freescale VF500 - MTD seems
> > > > > > to be broken.
> > > > > >
> > > > > > Bisect pointed me to commit 7c27338c728e39ef47c83d101959aa332506969d
> > > > > > ("mtd: rawnand: Move the ->exec_op() method to nand_controller_ops")
> > > > > > as reason of failure to find MTD partitions.
> > > > > >
> > > > > > Toradex Colibri VF50 on Iris board (ARMv7, UP, Cortext-A5, NXP VF500,
> > > > > > 128 MB RAM, 128 MB NAND, Systemd: v232) booted from NFS root (NFSv4)
> > > > > > trying to mount UBIFS from NAND/MTD. Board uses VF610 NAND driver.
> > > > > >
> > > > > > The MTD partitions are missing entirely (nothing under /dev/mtd).
> > > > > > In the logs you can also see:
> > > > > > [ 1.232161] UBI error: cannot open mtd ubi2, error -2
> > > > > >
> > > > > > Attached - dmesg.log
> > > > > >
> > > > > > Let me know if you need defconfig or any other information.
> > > > >
> > > > > Thank you very much for testing and reporting the bug!
> > > > >
> > > > > Could you please test with this diff applied [1] please? We discussed
> > > > > with Boris and we think it should fix your setup (and all others also
> > > > > impacted).
> > > > >
> > > > > [1] http://code.bulix.org/r1m99i-509201
> > > >
> > > > error: patch failed: drivers/mtd/nand/raw/nand_base.c:4399
> > > > error: drivers/mtd/nand/raw/nand_base.c: patch does not apply
> > > >
> > > > Maybe you have a git tree with this somewhere?
> > >
> > > Yep: https://github.com/bbrezillon/linux/tree/nand/next-fix
> >
> > Works fine now, thanks!
> > Tested-by: Krzysztof Kozlowski <krzk@kernel.org>
>
> Although the patch fixed the issue... but it seems it is not in
> linux-next. The next is broken since almost two weeks.
>
> Best regards,
> Krzysztof

Sorry for the huge delay, fixup applied.


Thanks,
Miquèl


\
 
 \ /
  Last update: 2018-12-06 21:15    [W:0.062 / U:4.892 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site