lkml.org 
[lkml]   [2018]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v14 01/11] livepatch: Change unsigned long old_addr -> void *old_func in struct klp_func
On Thu, 29 Nov 2018, Petr Mladek wrote:

> The address of the to be patched function and new function is stored
> in struct klp_func as:
>
> void *new_func;
> unsigned long old_addr;
>
> The different naming scheme and type is derived from the way how
> the addresses are set. @old_addr is assigned at runtime using
> kallsyms-based search. @new_func is statically initialized,
> for example:
>
> static struct klp_func funcs[] = {
> {
> .old_name = "cmdline_proc_show",
> .new_func = livepatch_cmdline_proc_show,
> }, { }
> };
>
> This patch changes unsigned log old_addr -> void *old_func. It removes
> some confusion when these address are later used in the code. It is
> motivated by a followup patch that adds special NOP struct klp_func
> where we want to assign func->new_func = func->old_addr respectively
> func->new_func = func->old_func.
>
> This patch does not modify the existing behavior.
>
> Suggested-by: Josh Poimboeuf <jpoimboe@redhat.com>
> Signed-off-by: Petr Mladek <pmladek@suse.com>
> ---
> include/linux/livepatch.h | 4 ++--
> kernel/livepatch/core.c | 6 +++---
> kernel/livepatch/patch.c | 18 ++++++++++--------
> kernel/livepatch/patch.h | 2 +-
> kernel/livepatch/transition.c | 4 ++--
> 5 files changed, 18 insertions(+), 16 deletions(-)

kernel/livepatch/patch.h also mentions old_addr in a comment.

You can add

Acked-by: Miroslav Benes <mbenes@suse.cz>

with that fixed.

Miroslav

\
 
 \ /
  Last update: 2018-12-03 14:24    [W:0.623 / U:0.028 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site