lkml.org 
[lkml]   [2018]   [Dec]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] debugobjects: Move printk out of db lock critical sections
From
Date
On 12/12/2018 06:39 PM, Andrew Morton wrote:
> On Wed, 12 Dec 2018 17:28:14 -0500 Waiman Long <longman@redhat.com> wrote:
>
>> The db->lock is a raw spinlock and so the lock hold time is supposed
>> to be short. This will not be the case when printk() is being involved
>> in some of the critical sections. In order to avoid the long hold time,
>> in case some messages need to be printed, the debug_object_is_on_stack()
>> and debug_print_object() calls are now moved out of those critical
>> sections.
>>
>> Holding the db->lock while calling printk() may lead to deadlock if
>> printk() somehow requires the allocation/freeing of debug object that
>> happens to be in the same hash bucket or a circular lock dependency
>> warning from lockdep as reported in https://lkml.org/lkml/2018/12/11/143.
>>
>> [ 87.209665] WARNING: possible circular locking dependency detected
>> [ 87.210547] 4.20.0-rc4-00057-gc96cf92 #1 Tainted: G W
>> [ 87.211449] ------------------------------------------------------
>> [ 87.212405] getty/519 is trying to acquire lock:
>> [ 87.213074] (____ptrval____) (&obj_hash[i].lock){-.-.}, at: debug_check_no_obj_freed+0xb4/0x302
>> [ 87.214343]
>> [ 87.214343] but task is already holding lock:
>> [ 87.215174] (____ptrval____) (&port_lock_key){-.-.}, at: uart_shutdown+0x3a3/0x4e2
>> [ 87.216260]
>> [ 87.216260] which lock already depends on the new lock.
>>
>> This patch was also found to be able to fix a boot hanging problem
>> when the initramfs image was switched on after a debugobjects splat
>> from the EFI code.
> Patch looks sensible, but I have a nit about the variable names.
>
>> --- a/lib/debugobjects.c
>> +++ b/lib/debugobjects.c
>> @@ -375,6 +375,8 @@ static void debug_object_is_on_stack(void *addr, int onstack)
>> struct debug_bucket *db;
>> struct debug_obj *obj;
>> unsigned long flags;
>> + bool debug_printobj = false;
> "debug_printobject" would be better, but this code already intermingles
> "obj" and "object".
>
>> + bool debug_chkstack = false;
> Not so good. Is it debug_chkstack or debug_checkstk or ...
>
> This file uses "check" consistently so let's not depart from that?
> Linux style is to avoid these tricky little abbreviations and to use
> full words.
>
> ie, debug_checkstack, please. Better would be debug_check_stack. Or
> simply check_stack: the "debug" doesn't add anything useful.
>
>
Thanks for the review. I have eliminated debug_printobj in the new v2 patch.

Cheers,
Longman

\
 
 \ /
  Last update: 2018-12-13 23:01    [W:0.118 / U:1.220 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site