lkml.org 
[lkml]   [2018]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] staging: wilc1000: correct inconsistent indenting
From
Date
On 11/29/18 7:24 AM, Joe Perches wrote:
> On Wed, 2018-11-28 at 19:17 +0100, Michael Straube wrote:
>> Correct inconsistent indenting reported by smatch.
> []
>> diff --git a/drivers/staging/wilc1000/wilc_spi.c b/drivers/staging/wilc1000/wilc_spi.c
> []
>> @@ -963,7 +963,7 @@ static int wilc_spi_read_int(struct wilc *wilc, u32 *int_status)
>> dev_err(&spi->dev,
>> "Unexpected interrupt(2):j=%d,tmp=%x,mask=%x\n",
>> j, tmp, unknown_mask);
>> - happened = 1;
>> + happened = 1;s a
>> }
>>
>> j++;
>
> Perhaps a little refactoring instead
> ---
> drivers/staging/wilc1000/wilc_spi.c | 12 +++++-------
> 1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/staging/wilc1000/wilc_spi.c b/drivers/staging/wilc1000/wilc_spi.c
> index 35ff432587fe..a38ddb1f0a1f 100644
> --- a/drivers/staging/wilc1000/wilc_spi.c
> +++ b/drivers/staging/wilc1000/wilc_spi.c
> @@ -927,7 +927,8 @@ static int wilc_spi_read_int(struct wilc *wilc, u32 *int_status)
> int ret;
> u32 tmp;
> u32 byte_cnt;
> - int happened, j;
> + bool unexpected_irq;
> + int j;
> u32 unknown_mask;
> u32 irq_flags;
> int k = IRG_FLAGS_OFFSET + 5;
> @@ -947,8 +948,6 @@ static int wilc_spi_read_int(struct wilc *wilc, u32 *int_status)
>
> j = 0;
> do {
> - happened = 0;
> -
> wilc_spi_read_reg(wilc, 0x1a90, &irq_flags);
> tmp |= ((irq_flags >> 27) << IRG_FLAGS_OFFSET);
>
> @@ -959,15 +958,14 @@ static int wilc_spi_read_int(struct wilc *wilc, u32 *int_status)
>
> unknown_mask = ~((1ul << spi_priv->nint) - 1);
>
> - if ((tmp >> IRG_FLAGS_OFFSET) & unknown_mask) {
> + unexpected_irq = (tmp >> IRG_FLAGS_OFFSET) & unknown_mask;
> + if (unexpected_irq)
> dev_err(&spi->dev,
> "Unexpected interrupt(2):j=%d,tmp=%x,mask=%x\n",
> j, tmp, unknown_mask);
> - happened = 1;
> - }
>
> j++;
> - } while (happened);
> + } while (unexpected_irq);
>
> *int_status = tmp;
>
>
Hi Joe,

that looks good to me.
Naming the loop condition unexpected_irq also improves readability.

I will send a new patch, thanks.
Michael

\
 
 \ /
  Last update: 2018-11-29 14:45    [W:0.052 / U:0.496 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site