lkml.org 
[lkml]   [2018]   [Oct]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v5 7/8] dt-binding: mtd: Document gpio-addr-flash
HI Boris


On Thu, Oct 4, 2018 at 12:19 AM Boris Brezillon
<boris.brezillon@bootlin.com> wrote:
>
> On Thu, 4 Oct 2018 00:14:15 +0200
> Boris Brezillon <boris.brezillon@bootlin.com> wrote:
>
> > On Wed, 3 Oct 2018 23:53:27 +0200
> > Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> wrote:
> >
> > > Hi Boris
> > > On Wed, Oct 3, 2018 at 11:27 PM Boris Brezillon
> > > <boris.brezillon@bootlin.com> wrote:
> > > >
> > > > On Wed, 3 Oct 2018 21:38:58 +0200
> > > > Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> wrote:
> > > >
> > > > > Add documentation for gpio-addr-flash. This binding allow creating
> > > > > flash devices that are paged using GPIOs.
> > > > >
> > > > > Cc: devicetree@vger.kernel.org
> > > > > Reviewed-by: Rob Herring <robh@kernel.org>
> > > > > Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
> > > > > ---
> > > > > .../bindings/mtd/gpio-addr-flash.txt | 54 +++++++++++++++++++
> > > > > 1 file changed, 54 insertions(+)
> > > > > create mode 100644 Documentation/devicetree/bindings/mtd/gpio-addr-flash.txt
> > > > >
> > > > > diff --git a/Documentation/devicetree/bindings/mtd/gpio-addr-flash.txt b/Documentation/devicetree/bindings/mtd/gpio-addr-flash.txt
> > > > > new file mode 100644
> > > > > index 000000000000..5006a26e1753
> > > > > --- /dev/null
> > > > > +++ b/Documentation/devicetree/bindings/mtd/gpio-addr-flash.txt
> > > > > @@ -0,0 +1,54 @@
> > > > > +Memory Mapped flash with some address lines addressed using GPIOs
> > > > > +
> > > > > +Handle the case where a flash device is mostly addressed using physical
> > > > > +line and supplemented by GPIOs. This way you can hook up say a 8MiB flash
> > > > > +to a 2MiB memory range and use the GPIOs to select a particular range.
> > > > > +
> > > > > + - compatible : "cfi-gpio-addr-flash"
> > > > > + - reg : Address range of the mtd chip that is memory mapped, this is,
> > > > > + on the previous example 2MiB.
> > > > > + - bank-width : Width (in bytes) of the bank. Equal to the
> > > > > + device width times the number of interleaved chips.
> > > > > + - gpios: List of GPIO specifiers that will be used to address the MSBs address
> > > > > + lines. The order goes from LSB to MSB.
> > > > > + - probe-type : (optional) "cfi_probe", "jedec_probe". How the mtd chip
> > > > > + is going to be probed. If omitted, assumed to be equal to "cfi_probe".
> > > >
> > > > Looks like other bindings are encoding the probe type in the
> > > > compatible [1][2], and we should probably follow what's been done by
> > > > others.
> > >
> > > If I understood it right, they are special cases of physmap_of_core.c
> > > https://elixir.bootlin.com/linux/v4.18.11/source/drivers/mtd/maps/physmap_of_core.c#L242
> > >
> > > The driver that handles the compatible is physmap_of_core.c, and afaik
> > > multiple drivers with the same
> > > compatible string is a very bad idea.
> >
> > Yes, I know.
> >
> > >
> > > We can convert the driver to something like Versatile or gemini, but
> > > then we will not support platform devices
> > >
> > > btw, the binding that I am used is used by:
> > > https://elixir.bootlin.com/linux/v4.18.11/source/drivers/mtd/maps/physmap_of_core.c#L91
> >
> > Actually, the more I think about it the more I realize this should
> > somehow be integrated to the physmap core logic. I mean, there's nothing
> > controller/platform specific in what the gpio-physmap driver does.
> >
> > We could basically add the msb_addr_gpios related fields to map_info,
> > let physmap.c and physmap_of_core.c call
> > devm_gpiod_get_array_optional() and, based on the returned value,
> > call simple_map_init() (when the pointer is NULL) or
> > gpio_addr_map_init() (when the pointer is valid).
>
> Or even better, let simple_map_init() call gpio_addr_map_init() when
> map->addr_gpios != NULL, so that you don't even have to duplicate the
> selection logic in physmap.c and physmap_of_core.c.
>

I am all in for the removal of duplicated code. But I have implemented
it slightly different, following gemini and versatile

In physmap_of_core.c

I have added

err = of_flash_probe_gpio(dev, dp, &info->list[i].map);
if (err){
iounmap(info->list[i].map.virt);
goto err_out;
}

and on gpio-addr-flash the code for DT is simply

int of_flash_probe_gpio(struct platform_device *pdev, struct device_node *np,
struct map_info *map)
{
struct async_state *state;

if (!of_device_is_compatible(np, "mtd,gpio-addr-flash"))
return 0;

state = devm_kzalloc(&pdev->dev, sizeof(*state), GFP_KERNEL);
if (!state)
return -ENOMEM;

return gpio_flash_probe_common(&pdev->dev, state, map);
}

You can take a look to the code at
https://github.com/ribalda/linux/tree/gpio-addr-flash-v6

once it is tested on hw I will commit to the list

I think now we are getting into something quite good :)

Thanks!

> >
> > gpio_addr_map_init() would still be implemented in gpio-addr-flash.c so
> > that we can still enable/disable support for this feature (providing
> > dummy wrappers when it's disabled). By doing that, we also keep a single
> > driver which matches a generic compatible string. We also stay
> > compatible with .c based board files.
>


--
Ricardo Ribalda

\
 
 \ /
  Last update: 2018-10-04 10:36    [W:0.052 / U:0.188 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site