lkml.org 
[lkml]   [2018]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] staging: axis-fifo: Fix line over 80 characters error
On Wed, Oct 24, 2018 at 11:18:17PM -0700, Joe Perches wrote:
> On Thu, 2018-10-25 at 09:05 +0300, Dan Carpenter wrote:
> > On Wed, Oct 24, 2018 at 05:05:53PM +0200, Aleksa Zdravkovic wrote:
> > > This patch fixes the checkpatch.pl warning:
> []
> > > diff --git a/drivers/staging/axis-fifo/axis-fifo.c b/drivers/staging/axis-fifo/axis-fifo.c
> []
> > > @@ -482,10 +482,10 @@ static ssize_t axis_fifo_write(struct file *f, const char __user *buf,
> > > spin_lock_irq(&fifo->write_queue_lock);
> > > ret = wait_event_interruptible_lock_irq_timeout
> > > (fifo->write_queue,
> > > - ioread32(fifo->base_addr + XLLF_TDFV_OFFSET)
> > > + ioread32(fifo->base_addr + XLLF_TDFV_OFFSET)
> > > >= words_to_write,
> > > - fifo->write_queue_lock,
> > > - (write_timeout >= 0) ? msecs_to_jiffies(write_timeout) :
> > > + fifo->write_queue_lock,
> > > + (write_timeout >= 0) ? msecs_to_jiffies(write_timeout) :
> > > MAX_SCHEDULE_TIMEOUT);
> >
> > The original was fine. Just leave it.
> >
> > Checkpatch.pl is only useful if it improves the readability for humans.
>
> True, but I think the original is just OK.
>
> Any suggestion on how to make the thing better?
>
> wait_event_interruptible_lock_irq_timeout is a fairly long
> identifier with multiple long arguments.
>
> It's as if it should be written here as
>
> ret = wait_event_interruptible_lock_irq_timeout(fifo->write_queue,
> ioread32(fifo->base_addr + XLLF_TDFV_OFFSET) >= words_to_write,
> fifo->write_queue_lock,
> write_timeout >= 0 ? msecs_to_jiffies(write_timeout) : MAX_SCHEDULE_TIMEOUT);
>
> where the longest is way over 80 chars, (140?) but I simply don't care
> because it's just that much more readable for me.
>
>

Thank you Dan and Joe for your feedback.

I don't have any suggestion how to improve this code otherwise.
I will try to find a way to improve it. Maybe we can define some
macros but I don't think it would help much.


\
 
 \ /
  Last update: 2018-10-25 16:44    [W:0.070 / U:0.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site