[lkml]   [2018]   [Oct]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] Change judgment len position
On Wed, 2018-10-24 at 10:03 -0700, Eric Dumazet wrote:
> On Wed, Oct 24, 2018 at 9:54 AM Joe Perches <> wrote:
> > I think if the point is to test for negative numbers,
> > it's clearer to do that before using min_t.and it's
> > probably clearer not to use min_t at all.
> >
> ...
> > if (len > sizeof(int))
> > len = sizeof(int);
> It is a matter of taste really,

Agree and hence my use of 'I think' above.

> I know some people (like me) sometimes
> mixes min() and max()

Not quite sure what you mean here by mixes.
mix up? If so, the < > inversions probably
have about the same error rate.

And I suppose there are cases where the
always set of len in uses like

len = min(len, 4);

are more costly (len being in a slow write
speed area of memory or some such) than the
other style of

if (len < 4)
len = 4;

I think that min() is easier to read in most

> I would suggest that if someones wants to change the current code, a
> corresponding test would be added in tools/testing/selftests/net?

 \ /
  Last update: 2018-10-24 19:19    [W:0.054 / U:3.836 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site