lkml.org 
[lkml]   [2018]   [Oct]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5 1/2] dt-bindings: iio: vadc: Update example to include unit address for node 'usb-id-nopull'
Hi Rob,

On Fri, Oct 05, 2018 at 03:47:43PM -0500, Rob Herring wrote:
> On Wed, Oct 03, 2018 at 05:14:31PM -0700, Matthias Kaehlcke wrote:
> > The node has a reg property, therefore its name should include a unit
> > address.
> >
> > Also change the name from 'usb_id_nopull' to 'usb-id-nopull' to follow
> > DT conventions.
>
> This is ADC channels?

yes

> If so, then DT convention would really be "adc@...".

ok, will update

> > Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
> > ---
> > Changes in v4:
> > - patch added to the series
> > ---
> > Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt b/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt
> > index d0c188e5c922..ff7aa5038ba6 100644
> > --- a/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt
> > +++ b/Documentation/devicetree/bindings/iio/adc/qcom,spmi-vadc.txt
> > @@ -112,7 +112,7 @@ Example:
> > io-channel-ranges;
> >
> > /* Channel node */
> > - usb_id_nopull {
> > + usb-id-nopull@VADC_LR_MUX10_USB_ID {
> > reg = <VADC_LR_MUX10_USB_ID>;
>
> Defines are generally used when there's not well defined numbering such
> as clock ids. Interrupts and addresses are generally well defined and
> don't need defines.

ok, I'll update this to use literals

Thanks for the review!

Matthias

\
 
 \ /
  Last update: 2018-10-11 21:12    [W:0.091 / U:9.344 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site