lkml.org 
[lkml]   [2018]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 4.4 00/37] 4.4.110-stable review
On Fri, Jan 05, 2018 at 04:25:33PM +0100, Thomas Voegtle wrote:
> On Fri, 5 Jan 2018, Greg Kroah-Hartman wrote:
>
> > On Thu, Jan 04, 2018 at 08:38:23PM +0100, Thomas Voegtle wrote:
> > >
> > > When I start 4.4.110-rc1 on a virtual machine (qemu) init throws a
> > > segfault and the kernel panics (attempted to kill init).
> > > The VM host is a Haswell system.
> > >
> > > The same kernel binary boots fine on a (other) Haswell system.
> > >
> > > I tried:
> > >
> > > 4.4.110-rc1 broken
> > > 4.4.109 ok
> > > 4.9.75-rc1 ok
> > >
> > > All systems are OpenSuSE 42.3 64bit.
> > >
> > > qemu is started only with:
> > > qemu-system-x86_64 -m 2048 -enable-kvm -drive
> > > file=tvsuse,format=raw,if=none,id=virtdisk0 -device
> > > virtio-blk-pci,scsi=off,drive=virtdisk0
> > >
> > > Am I the only one who sees this? Has anyone booted that kernel on qemu?
> >
> > I've now released 4.4.110, which had 4 more patches on top of what
> > 4.4.109-rc1 had in it, that should hopefully resolve these issues.
> >
> > Can you test that and let me know if you still have problems?
>
> It's fixed. I can boot 4.4.110 on qemu without problems so far.

Yeah!!!

> ./test_vsyscall_64 still fails though, like Kees wrote about 4.4.110-rc1
> https://lkml.org/lkml/2018/1/5/123
>
> That's another issue?

Yes it is, that's next up to get resolved.

thanks for testing and letting me know,

greg k-h

\
 
 \ /
  Last update: 2018-01-05 16:49    [W:0.114 / U:8.908 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site