lkml.org 
[lkml]   [2018]   [Jan]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectNetwork interface "stops working"
Date
I just got a new broadband delivered at home. It is "Hyperoptic 1Gbps fiber" which comes as a ethernet connector at home. I wasn’t around
when they connected up everything, so I’m not sure *where* the fiber starts, but either way, I have an ethernet jack in one of my rooms.

They also provided me with a ZTE router. I have need for my own services (firewalling, NATing, IPSEC and what not), so don’t want to use
the provided router..

However, I’m having serious trouble keeping the interface up! Works for a few minutes and then just “stops working”. Don’t know why, there’s
nothing in the logs or from dmesg..

Taking the interface down and then up again usually solves it. For a few minutes.

Also, when running the interface (a Intel 82576 Gigabit dual port, using the igb driver - tried e1000 and e1000e but they don’t find any interfaces),
in 1Gbps mode, the interface starts flapping up and down and I can’t get a connection at all. So my interface definition runs a script to use
ethtool to set the speed to 100Mbps, full duplex, no auto negotiation. Which “kinda” works (for a while, hence my problems).

Because the provided router works just fine, I’m sure it’s something on my Linux box (Debian GNU/Linux Jessie) that does it.. I’ve tried running
it without any iptables, in both static and DHCP mode but same problem..

I’m not a complete beginner with Linux nor networks, but this is to “close to the hardware” for me. I’m at a loss to what else to try..

This isn’t a new machine, it have served me very well for five years give or take and I’ve never had any problems with it (not to say that it still
can’t be hardware problems, but I find that somewhat unlikely at the moment).


Could anyone please advice to what I can try to try to pinpoint the problem (and/or possibly fix it)?
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2018-01-22 11:10    [W:0.041 / U:4.732 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site