lkml.org 
[lkml]   [2017]   [Sep]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH -next] spi: fix spi-sprd-adi build errors when COMPILE_TEST=y
From
Date
On 09/21/17 09:49, Mark Brown wrote:
> On Thu, Sep 21, 2017 at 09:10:04AM -0700, Randy Dunlap wrote:
>
>> +++ linux-next-20170921/drivers/spi/Kconfig
>> @@ -625,6 +625,7 @@ config SPI_SIRF
>> config SPI_SPRD_ADI
>> tristate "Spreadtrum ADI controller"
>> depends on ARCH_SPRD || COMPILE_TEST
>> + depends on HWSPINLOCK
>> help
>> ADI driver based on SPI for Spreadtrum SoCs.
>
> Why is this a more sensible fix than providing stubs for HWSPINLOCK?
>

There are already stubs there. I'll send an updated patch.

--
~Randy

\
 
 \ /
  Last update: 2017-09-21 20:01    [W:0.031 / U:4.872 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site