[lkml]   [2017]   [Aug]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 3/4] x86/asm: Make alternative macro interfaces more clear and consistent
On Thu, Aug 31, 2017 at 09:11:54AM -0700, Linus Torvalds wrote:
> On Thu, Aug 31, 2017 at 7:11 AM, Josh Poimboeuf <> wrote:
> >
> > Make the following changes:
> >
> > - Give alternative_io(), alternative_call(), and alternative_call_2()
> > consistent interfaces. The constraints are provided by use of the
> > OUTPUTS(), INPUTS(), and CLOBBERS() macros.
> I really think those macro names are way too generic. Putting them in
> a core header file and expecting people to never use them is wrong.
> So please rename things like "OUTPUTS()" to "ASM_OUTPUTS()" or something.
> Yes, it might look slightly worse in the asm expansion. And no, we
> don't actually seem to have anybody using those right now, but I did
> find people using both OUTPUT and INPUT in some C files, so those
> names are clearly not very unique or distinct.

Makes sense. I can prepend them with "ASM_".

> On the whole, I'm not entirely sure this is the right approach. I
> think we should
> (a) approach clang about their obvious bug (a compiler that clobbers
> %rsp because we mark it as in/out is clearly buggy)

Yeah, this would be a good idea.

> (b) ask gcc people if there's some other alternative that would work
> with clang as-is rather than the "mark %rsp register as clobbered"
> I couldn't actually find the %rsp trick in any docs, I assume it came
> from discussions with gcc developers directly. Maybe there is
> something else we could do that doesn't upset clang?

There have been a few other ideas which have *almost* worked:

1) Make the 'register void *__sp asm(_ASM_SP)' a global variable instead
of a local one. This works for GCC and doesn't break clang. However
it resulted in a lot of changed code on the GCC side. It looked like
some optimizations had been disabled, even in functions which
shouldn't have been affected.

2) Put "sp" in the clobbers list instead of as an i/o constraint. This
mostly works for GCC, and doesn't break clang. However, it causes
GCC to insert a "lea -0x10(%rbp),%rsp" in the epilogue of every
affected function.

I can ping the GCC list again and see if there are any other ideas.

> Perhaps we can mark the frame pointer as an input, for example? Inputs
> also have the advantage that appending to the input list doesn't
> change the argument numbering, so we don't need to worry about
> numbered arguments (not that I mind the naming of arguments, but I
> kind of hate having to do it as part of this series).

I'll give it a shot :-)

I'm about to disappear for a few days to celebrate the American labor
movement, so I'll try to follow up on this stuff next week.


 \ /
  Last update: 2017-08-31 19:26    [W:0.116 / U:16.248 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site