lkml.org 
[lkml]   [2017]   [Jul]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH net] xgene: Don't fail probe, if there is no clk resource for SGMII interfaces
On Thu, Jul 27, 2017 at 02:03:42PM -0700, Laura Abbott wrote:
> This change causes boot failures for me on my APM Mustang system running
> Fedora rawhide:
>
> [ 16.669089] Synchronous External Abort: synchronous external abort (0x9600000
> [ 16.669099] Internal error: : 96000010 [#1] SMP
> [ 16.669103] Modules linked in: xgene_enet(+) at803x realtek mdio_xgene xgenes
> [ 16.669127] CPU: 2 PID: 534 Comm: systemd-udevd Not tainted 4.13.0-0.rc1.git1
> [ 16.669128] Hardware name: AppliedMicro X-Gene Mustang Board/X-Gene Mustang 6
> [ 16.669131] task: ffff8003e6f8ce00 task.stack: ffff8003e4fd8000
> [ 16.669144] PC is at xgene_enet_wr_mac+0xa0/0x128 [xgene_enet]
> [ 16.669152] LR is at xgene_enet_wr_mac+0x64/0x128 [xgene_enet]

on the first glance I don't see anything clock related there.

What firmware version is installed on your mustang board ? I saw
ethernet related crashes with mustang boards because the device tree
in firmware was too old for the xgene ethernet driver.

Thoms.

--
Crap can work. Given enough thrust pigs will fly, but it's not necessarily a
good idea. [ RFC1925, 2.3 ]

\
 
 \ /
  Last update: 2017-07-27 23:40    [W:0.070 / U:15.740 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site