lkml.org 
[lkml]   [2017]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subject[PATCH v3 0/8] gpio: mockup: updates for 4.13
    Date
    v1 -> v2:
    - omit applied patches
    - use kstrtoint_from_user() for debugfs input sanitization
    - add a patch improving the code in gpio_mockup_event_write()
    - bail out from gpio_mockup_event_write() on invalid input even when
    nobody is listening for events

    v2 -> v3:
    - added the patch replacing devm_kzalloc() with devm_kcalloc() where
    applicable

    Bartosz Golaszewski (8):
    gpio: mockup: improve the debugfs input sanitization
    gpio: mockup: tweak gpio_mockup_event_write()
    gpio: mockup: refuse to accept an odd number of GPIO ranges
    gpio: mockup: improve readability
    gpio: mockup: don't return magic numbers from probe()
    gpio: mockup: improve the error message
    gpio: mockup: add myself as author
    gpio: mockup: use devm_kcalloc() where applicable

    drivers/gpio/gpio-mockup.c | 67 ++++++++++++++++++++++++----------------------
    1 file changed, 35 insertions(+), 32 deletions(-)

    --
    2.9.3

    \
     
     \ /
      Last update: 2017-06-12 01:47    [W:4.190 / U:0.808 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site