lkml.org 
[lkml]   [2017]   [Jun]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Hi,

    On 21/06/17 10:16, Viresh Kumar wrote:
    > Use the standard way of returning errors instead of returning 0(failure)
    > OR 1(success) and making it hard to read.
    >
    > Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
    > ---
    > arch/arm/kernel/topology.c | 2 +-
    > drivers/base/arch_topology.c | 8 ++++----
    > 2 files changed, 5 insertions(+), 5 deletions(-)
    >
    > diff --git a/arch/arm/kernel/topology.c b/arch/arm/kernel/topology.c
    > index bf949a763dbe..a7ef4c35855e 100644
    > --- a/arch/arm/kernel/topology.c
    > +++ b/arch/arm/kernel/topology.c
    > @@ -111,7 +111,7 @@ static void __init parse_dt_topology(void)
    > continue;
    > }
    >
    > - if (topology_parse_cpu_capacity(cn, cpu)) {
    > + if (!topology_parse_cpu_capacity(cn, cpu)) {

    Not sure why you want to change this.

    I currently read it as "if cpu_capacity parsing succedeed" continue with
    next CPU, otherwise we set cap_from_dt to false and fall back to using
    efficiencies.

    Thanks,

    - Juri

    \
     
     \ /
      Last update: 2017-06-22 20:01    [W:4.142 / U:0.008 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site