lkml.org 
[lkml]   [2017]   [Jun]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3] memcg: refactor mem_cgroup_resize_limit()
[Sorry for a late reponse]

On Sun 04-06-17 14:18:07, Yu Zhao wrote:
> mem_cgroup_resize_limit() and mem_cgroup_resize_memsw_limit() have
> identical logics. Refactor code so we don't need to keep two pieces
> of code that does same thing.
>
> Signed-off-by: Yu Zhao <yuzhao@google.com>
> Acked-by: Vladimir Davydov <vdavydov.dev@gmail.com>

It is nice to see removal of the code duplication. I have one comment
though

[...]

> @@ -2498,22 +2449,24 @@ static int mem_cgroup_resize_memsw_limit(struct mem_cgroup *memcg,
> }
>
> mutex_lock(&memcg_limit_mutex);
> - if (limit < memcg->memory.limit) {
> + inverted = memsw ? limit < memcg->memory.limit :
> + limit > memcg->memsw.limit;
> + if (inverted) {
> mutex_unlock(&memcg_limit_mutex);
> ret = -EINVAL;
> break;
> }

This is just too ugly and hard to understand. inverted just doesn't give
you a good clue what is going on. What do you think about something like

/*
* Make sure that the new limit (memsw or hard limit) doesn't
* break our basic invariant that memory.limit <= memsw.limit
*/
limits_invariant = memsw ? limit >= memcg->memory.limit :
limit <= mmecg->memsw.limit;
if (!limits_invariant) {
mutex_unlock(&memcg_limit_mutex);
ret = -EINVAL;
break;
}

with that feel free to add
Acked-by: Michal Hocko <mhocko@suse.com>
--
Michal Hocko
SUSE Labs

\
 
 \ /
  Last update: 2017-06-13 13:36    [W:0.158 / U:1.468 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site