[lkml]   [2017]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subjectcleanup UUID types V6
Hi all,

this series, which is a combined effort from Amir, Andy and me introduces
new uuid_t and guid_t type names that are less confusing than the existing
types, adds new helpers for them and starts switching the fs code over to
it. Andy has additional patches on top to convert many of the users
that use char arrays for UUIDs and GUIDs to these (or rather a predecessor
for now until updated).

Changes since V5:
- fix the AFS revert to respect endianess
- rename uuid_to_bin to uuid_parse

Changes since V4:
- removed the patch to remove uuid_be for now
- move the md patch to the front of the queue
- remove the union for V1 uuids and provide accessors instead
- new patch to set s_uuid for tmpfs
- revert the patch that moved struct uuid_v1 from afs to the core
- implement the fsid generation differently in XFS due to the
change above
- add a MAINTAINERS entry

Changes since V3:
- stop exposing uuid_be/uuid_t to userspace
- remove uuid_be entirely

Changes since V2:
- various cleanups

 \ /
  Last update: 2017-05-31 18:27    [W:0.129 / U:2.320 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site