lkml.org 
[lkml]   [2017]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v2 4/7] gpio: mockup: improve readability
On Wed, May 31, 2017 at 1:53 PM, Bartosz Golaszewski <brgl@bgdev.pl> wrote:
> 2017-05-30 20:55 GMT+02:00 Andy Shevchenko <andy.shevchenko@gmail.com>:
>> On Tue, May 30, 2017 at 11:58 AM, Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>>> We currently shift bits here and there without actually explaining
>>> what we're doing. Add some helper variables with names indicating
>>> their purpose to improve the code readability.
>>
>>> + /* Each chip is described by two values. */
>>> + num_chips = gpio_mockup_params_nr / 2;
>>> +
>>> + chips = devm_kzalloc(dev, sizeof(*chips) * num_chips, GFP_KERNEL);
>>
>> It's effectively
>> devm_kcalloc()
>> or
>> devm_kmalloc_array()
>> depending on the requirement of zeroing a memory chunks.

> Is there any advantage to using one of these here?

Yes, though subtle one in this case. The caller will not care about
(possible) overflow in multiplication.
Other (micro)optimizations might be in place in the future as well,
but I dunno about this.

I would suggest to change.

P.S. And of course if you don't need zeroed area it would be (slight?)
performance impact I suppose.

--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2017-05-31 16:58    [W:0.083 / U:0.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site