lkml.org 
[lkml]   [2017]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC 09/10] x86/mm: Rework lazy TLB to track the actual loaded mm
On Wed, 10 May 2017, Ingo Molnar wrote:
>
> * Thomas Gleixner <tglx@linutronix.de> wrote:
>
> > On Sun, 7 May 2017, Andy Lutomirski wrote:
> > > /* context.lock is held for us, so we don't need any locking. */
> > > static void flush_ldt(void *current_mm)
> > > {
> > > + struct mm_struct *mm = current_mm;
> > > mm_context_t *pc;
> > >
> > > - if (current->active_mm != current_mm)
> > > + if (this_cpu_read(cpu_tlbstate.loaded_mm) != current_mm)
> >
> > While functional correct, this really should compare against 'mm'.
> >
> > > return;
> > >
> > > - pc = &current->active_mm->context;
> > > + pc = &mm->context;
>
> So this appears to be the function:
>
> static void flush_ldt(void *current_mm)
> {
> struct mm_struct *mm = current_mm;
> mm_context_t *pc;
>
> if (this_cpu_read(cpu_tlbstate.loaded_mm) != current_mm)
> return;
>
> pc = &mm->context;
> set_ldt(pc->ldt->entries, pc->ldt->size);
> }
>
> why not rename 'current_mm' to 'mm' and remove the 'mm' local variable?

Because you cannot dereference a void pointer, i.e. &mm->context ....

Thanks,

tglx

\
 
 \ /
  Last update: 2017-05-10 21:21    [W:0.077 / U:13.788 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site